0.2.2 installation woes

SoluteDNS for WHMCS v2.xx.xxx and lower
Post Reply
den
Registered
Posts: 2
Joined: 06 Jan 2016, 06:48

06 Jan 2016, 16:52

Hi guys,

After i install 0.2.2 into /modules/addons and then navigate to Setup > Addon Modules in the WHMCS admin UI, I get error 500 server error. Removing the solutedns folder returns things back to normal. Has anyone else experienced this?

Unfortunately my web hosting provider has disabled error logging so thought I'd check in here while that is getting sorted out.

My WHMCS version is 6.1.1 and PHP is at 5.4. Any assistance would be appreciated.

DP
User avatar
Daniel
Support
Posts: 198
Joined: 02 Aug 2013, 17:50

07 Jan 2016, 15:05

Sorry to hear you having trouble installing SoluteDNS.

I'm not fully sure about the hosting provider disabling error messaging will effect the WHMCS error displaying capability but you can try to enable 'Display Errors' at the WHMCS admin area -> Setup -> General Settings -> Other

Normally this should return a error message.

Also see: http://docs.whmcs.com/Blank_Pages

A typical reason for this issue is for example IonCube is lower as v5. SoluteDNS 0.2.x requires IonCube v5 or higher.
den
Registered
Posts: 2
Joined: 06 Jan 2016, 06:48

14 Jan 2016, 09:18

Thanks Daniel for your considered reply. My web host (eventually) enabled error logging and you were spot on - IonCube needs to be upgraded:
PHP Fatal error: The file xxx/modules/addons/solutedns/solutedns.php cannot be decoded by this version of the ionCube Loader.
User avatar
Daniel
Support
Posts: 198
Joined: 02 Aug 2013, 17:50

14 Jan 2016, 17:25

Thank you for reporting back! Your hosting provider should be able to upgrade IonCube to it's last released version. It's fully compatible with older releases and is only a small upgrade to do.
Post Reply