WHMCS 6 Auto updater cannot verify downloaded package

SoluteDNS for WHMCS v2.xx.xxx and lower
Post Reply
User avatar
Daniel
Support
Posts: 199
Joined: 02 Aug 2013, 17:50

26 Oct 2016, 11:50

In WHMCS v6 SoluteDNS may show an error saying the downloaded update package could not be verified when using the updater. Due to a bug in the PHPseclibary included in WHMCS v6 the signature verification fails. The bug was fixed in 2012 but doesn't seem to be included in the WHMCS v6 package.

Please replace the RSA.php file which can be found in: vendor/phpseclib/phpseclib/phpseclib/Crypt with the file attached to this post.

Please note WHMCS v7 is not affected by this issue, do not use the file attached to this post when using WHMCS v7!
You do not have the required permissions to view the files attached to this post.
Post Reply