missing sql tables

SoluteDNS for WHMCS v2.xx.xxx and lower
Post Reply
hod
Registered
Posts: 3
Joined: 18 Dec 2015, 15:51

26 Jun 2018, 14:58

Fresh install 2.17.003-17003


Oops!
Something went wrong and we couldn't process your request.
Please go back to the previous page and try again.

If the problem persists, please contact us.

« Back to Homepage

For additional assistance, please reference the WHMCS TroubleShooting Guide »

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'xxx_whmcs.mod_solutedns_settings' doesn't exist in /home/xxxx/public_html/klanten/vendor/illuminate/database/Connection.php:333
User avatar
Daniel
Support
Posts: 200
Joined: 02 Aug 2013, 17:50

28 Jun 2018, 10:48

Please try SoluteDNS v2.17.004 (18001) at: viewtopic.php?f=17&t=86&p=239#p239 or for older IonCube versions SoluteDNS v0.17.004 (17004).

[Moved topic to: Legacy Forum]
hod
Registered
Posts: 3
Joined: 18 Dec 2015, 15:51

18 Jul 2018, 10:13

with release: Last release: SoluteDNS v2.17.004 (18001) (encoded for PHP 5.6 & 7.2)


on php 7.2:
For additional assistance, please reference the WHMCS TroubleShooting Guide »

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'dbname_whmcs.mod_solutedns_settings' doesn't exist in /path/public_html/klanten/modules/addons/solutedns/core.php:328
hod
Registered
Posts: 3
Joined: 18 Dec 2015, 15:51

18 Jul 2018, 12:58

manual created the missing tables from: https://github.com/solutedns/WHMCS-Comm ... utedns.php

but still missing some "pro" tables:
PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'databasenamewhmcs.mod_solutedns_products' doesn't exist in /path/public_html/klanten/modules/addons/solutedns/models/main.php:205
User avatar
Daniel
Support
Posts: 200
Joined: 02 Aug 2013, 17:50

22 Jul 2018, 17:29

I'm not sure what you are trying to do but it seems like your database is messed up. You cannot use the Community Edition database tables with any v2.x.xxx (or v3.x.xxx) release as they are not compatible. I would either recommend to restore your last working back-up or remove all SoluteDNS database tables and do a fresh setup.
Post Reply